Problemi di settings

Non riesco a capire se sia un problema solo mio o è il pack grafico che crea problemi.

Stavo giocando in un mondo in creativa con alinox e avevo questo brutto gioco grafico per cui gli oggetti in lontananza di vedevano male. Ho inizialmente legato il problema al fatto che non ho uno schermo hd, ma poi ho scoperto che l’impostazione mipmap che dovrebbe rendere migliori gli oggetti in lontananza era off, così ho provato ad abilitarla.

Crash, ogni volta che provo ad abilitare la mipmap il gioco crasha e non risponde. È legato al pack di mod?

1 Mi Piace

Ho controllato adesso, succede anche a me.

Il mipmap non migliora la grafica bensì velocizza il rendering dei modelli. Usare il mipmap richiede più memoria sulla scheda video, forse la avete esaurita ed è crashato il gioco. Fai conto che per ogni texture di ogni blocco ne vengono salvate diverse copie con diverse risoluzioni. Considera quanti blocchi ci sono nel modpack. Non è sostenibile.
Se volete approfondire: https://www.khronos.org/opengl/wiki/Texture#Mip_maps

1 Mi Piace

Tengo però una 970 :eyes: dovrebbe bastare …

Dipende a quanto avete impostato il mipmap level. Più è alto e più memoria verrà occupata. Considerando la quantità dei blocchi credo che 4GB li occupi in fretta. Adesso faccio una prova sulla 2080

1 Mi Piace

Ho chiuso e riaperto ed in un certo senso si è sistemato. Il problema che avevo era qualcosa dovuto alla bassa qualità dello schermo, giocando con una rendering di 16 chunk il gioco cercava di renderizzare i blocchi lontani comunque con la stessa qualità di pixel, e quindi muovere la telecamera in qualunque modo dava un effetto disturbante come l’assenza di segnale su una tv a tubo catodico, una specie di “sabbia” sullo schermo. Adesso sembra migliorato

Si questo è quello che accade senza mipmap. La gpu renderizza modelli con texture elevata in una quantità ridotta di pixel creando degli artifacts

EDIT: Io stavo giocando con mipmap level max senza essermene accorto. Occupa 2GB della gpu memory. Ho provato a cambiare il livello di mipmap e si è freezato come quando imposti una shader. Riavviare il modpack ha fixato. Durante il cambio del livello ho raggiunto un picco anomalo di RAM (https://prnt.sc/rl2g12)

avevo messolo solo liv 1 appunto per vedere quanto potesse reggere.

Prova a cambiare il mipmap prima di entrare in game. Dovresti alleggerire lo stress sulla scheda video

1 Mi Piace

Cambiare il livello di mipmap freeza spesso i computer meno performanti anche in vanilla da quello che mi ricordo, quindi quello che vi succede è piuttosto normale

Aggiorno, non solo è molto faticoso cambiare impostazione mipmap anche fuori dal mondo(nel menù principale), spendendo 20 minuti buoni, ma in più quando chiudo il launcher e riapro non vengono salvate le impostazioni grafiche che ho messo, né per il mipmap nè per le altre… C’è un modo di far si che vengano salvate senza doverle settare ogni volta?

Cambiare il livello di mipmap freeza. Ce ne eravamo accorti con @Akonitas una settimana fa.
Puoi delucidarci sul fatto che è cambiato qualcosa Ako?

Ho visto che si può fare comunque, ma ci mette davvero tanto… Spero più che altro di non dover continuare a farlo ogni volta che si resettano le impostazioni

Per quanto riguarda il lag nel cambiare il mipmap level non c’è nulla da fare, i blocchi sono tanti e questo richiede un sacco di tempo. Per quanto riguarda il reset dei settings ti rimando a questo post:


Se non ci sono altri problemi chiuderei il topic